Reverb on Vox ac30ch (head)

Contemporary amp builders and manufacturers.

Reverb on Vox ac30ch (head)

Postby deepeedoubleu on Fri Feb 24, 2017 3:13 am

Hi all,

I just bought a used vox ac30ch. Its the first tube amp ive owned. I am finding that when i first set up and start playing my reverb isnt working, but it begins start coming through after playing a few minutes. I understand that you should let a tube amp sit for a little while to let the tubes heat up before playing, but does the reverb rely on the amp heating up? Ive let the amp heat up about 30 seconds to a minute before hitting the standby off. Should i be letting it warm up for longer? Is this the reason it is taking time for the reverb to start working?

Also, i am getting a low buzzing noise which becomes louder when i use some pedals (overdrive pedals). The buzzing isnt a huge deal as the volume i normally practice at keeps the buzzing low. I am wondering if i should bring the amp to get checked in case it got knocked around in shipping. I am mostly concerned about the reverb right now.

Can anyone help throw some knowledge my way?
deepeedoubleu
Peasant
 
Posts: 1
Joined: Fri Feb 24, 2017 2:53 am

Re: Reverb on Vox ac30ch (head)

Postby tubeswell on Thu Mar 16, 2017 11:44 pm

No that doesn't sound right. Take it to a tech
He who dies with the most tubes... wins.
tubeswell
Peasant
 
Posts: 41
Joined: Thu Dec 15, 2011 2:26 pm


Return to Modern Guitar Amps and Builders

Who is online

Users browsing this forum: No registered users and 0 guests