YBA-1 for Torren.

Gibson, Valco, Gretsch, and more

Re: YBA-1 for Torren.

Postby Torren61 on Thu Jan 05, 2017 7:19 am

New Amp Day! The head arrived.

Image

Image

Image

Image
Torren61
Court Jester
 
Posts: 54
Joined: Mon May 25, 2009 7:37 pm

Re: YBA-1 for Torren.

Postby Torren61 on Thu Jan 05, 2017 7:25 am

He probably forgot to include the plate that covers the chassis that I included when i shipped the head to him.

Image

He probably didn't know not to ship the head with the preamp tubes in the sockets.

Image

He probably didn't know to wrap the head and pack it well before shipping across the Atlantic Ocean from Gothenburg to Fortuna, CA.

Image

I'll need to find a tech around here to go over the head before I plug it in. I'll have to experiment to figure out what switches and knobs do what as there's no manual of any kind.

Image

Image
Torren61
Court Jester
 
Posts: 54
Joined: Mon May 25, 2009 7:37 pm

Re: YBA-1 for Torren.

Postby Torren61 on Thu Jan 05, 2017 7:26 am

What a horrible experience.
Torren61
Court Jester
 
Posts: 54
Joined: Mon May 25, 2009 7:37 pm

Re: YBA-1 for Torren.

Postby Gooch on Thu Jan 05, 2017 2:32 pm

That sucks, dude. He seemed alright from his posts. Hopefully the amp kicks ass and it all works out.

:cheers:
Dying ain't much of a living.
Gooch
Baron
 
Posts: 2513
Joined: Sat Jun 16, 2001 7:01 am
Location: Austin TX

Re: YBA-1 for Torren.

Postby Vortexion on Thu Jan 05, 2017 3:53 pm

Holy sh*t. :shock: :cry:
Vortexion
Newt
 
Posts: 1251
Joined: Thu Jan 10, 2008 4:28 pm
Location: Norwich, UK

Re: YBA-1 for Torren.

Postby Gooner01 on Thu Jan 05, 2017 8:03 pm

Where did all that rust come from? :shock:
Gooner01
Peasant
 
Posts: 20
Joined: Fri Dec 09, 2011 12:41 pm

Re: YBA-1 for Torren.

Postby Vortexion on Thu Jan 05, 2017 8:54 pm

Good point. It certainly wasn't there in this earlier shot: Image
Vortexion
Newt
 
Posts: 1251
Joined: Thu Jan 10, 2008 4:28 pm
Location: Norwich, UK

Re: YBA-1 for Torren.

Postby serdontos on Thu Jan 05, 2017 11:37 pm

Yikes :Zap: :Zap:
serdontos
Peasant
 
Posts: 8
Joined: Fri May 23, 2008 6:49 am

Re: YBA-1 for Torren.

Postby zarfnober on Fri Jan 06, 2017 1:29 am

I've followed this post, and have a couple questions for you; do you still have your old EL34's that are in the photos? You didn't send those to him, did you?

Hope the amp sounds good, hate seeing this kind of stuff happen.

Rocco
zarfnober
Peasant
 
Posts: 47
Joined: Wed Mar 19, 2014 2:23 am

Re: YBA-1 for Torren.

Postby Torren61 on Fri Jan 06, 2017 1:54 am

The head came with three Rogers 12AX7s and a pair of Sylvania EL34s. One of the center posts broke on an EL34. I bought a pair of KT66s (that's right isn't it? Not at home right now). I didn't send him any tubes. He sent back the head, two EL34s, two EF86s, one 12AX7.

I found a local tech. He said it sounds like a basket case and wasn't even interested in looking at it without an old and new schematic, which if course I cannot provide. Very rude guy.

I swapped out the fuse to a 3A, pulled the EL34s, plugged into a Music Man 4X12 cab and powered through a Variac. I brought the amp up slowly and there was no smoke. Installed the power tubes and plugged in a guitar and powered up. No glow to the EL34s.

I turned it off and tested across the fuses for continuity and that was good. Looked at the preamp tubes and found the two EF86 tubes. Pulled the middle and swapped in a 12AX7. Turned on the amp again and got sound!

I need more time to figure out what does what but it does work. Cleans are very clean with a lot of low noise headroom. It seems to have various gain stages from crunchy to face melting. So far so good.

I'll post clips when/if I ever get time off from work. My schedule has been grueling lately. Like I said, the head sounds good. The cab is very dark but I have a U.K. Greenback on the way. It should sound a whole lot less dark.
Torren61
Court Jester
 
Posts: 54
Joined: Mon May 25, 2009 7:37 pm

Re: YBA-1 for Torren.

Postby Gooner01 on Sat Jan 07, 2017 1:05 pm

Looks like you'll have a decent amp once you've cleaned it up a bit. The work Jesper did initially looked really good.
Gooner01
Peasant
 
Posts: 20
Joined: Fri Dec 09, 2011 12:41 pm

Re: YBA-1 for Torren.

Postby Torren61 on Sat May 20, 2017 3:55 am

It worked for a bit and then the sound faded out. I bought a DeLisle Studio head and matching 2X12 cab and asked Jer if he could get the head Jesper built figured out. He said sure so i mailed him the head. Then Jer got a lot of orders and couldn't work on the head so he's mailing it back to me. :excited:
Torren61
Court Jester
 
Posts: 54
Joined: Mon May 25, 2009 7:37 pm

Re: YBA-1 for Torren.

Postby Torren61 on Fri Jun 09, 2017 4:53 am

Good news to a long and drawn out saga filled with disappointment and drama. Jer was able to get to my amp before shipping it back. He fixed a short and the head sounds great. There are a lot of control options that are going to take me a long time to figure out. I think it's been wired to bring in the EF86 and mix it with the 12AX7s or dial it down altogether. The cleans of this head are REALLY nice. A variety of crunch sounds can be found in it as well.

Was it worth the hassle? Nope.
Torren61
Court Jester
 
Posts: 54
Joined: Mon May 25, 2009 7:37 pm

Previous

Return to Miscellaneous American Amplifiers

Who is online

Users browsing this forum: Google [Bot] and 1 guest