Sound City Bass 150

20 Studio, 50+, 50PA, 50R, L100, B100, L120, L120PA, L120R, 120 SLAVE, B120, B150, L150, L200, B200, Concord, and SMF

Sound City Bass 150

Postby macombredesigns on Sat Aug 23, 2014 11:34 pm

I recently acquired a early 70's Sound City Bass 150. No tubes, listed as a "fixer-upper". After fixing some bad solder points and I started checking out the transformers. The mains transformer is putting out 414 VAC on the HT secondary, 41 VAC on the bias secondary, and 6.7 VAC on the heaters. With the feed to the first filter section disconnected form the bridge rectifier, I'm getting 430 VDC on the center tap of the OT. With the first filter section connected to the rectifiers, I get runaway current (I'm bringing the line voltage up slowly on a variac) and what sounds like arcing in the mains transform. After taking a closer look at the first filter section, the second (closer to ground) cap is reading a dead short. I removed the 220k resistor across it and tested it out of circuit, seems ok. Before I order the new filter caps, does it sound like I've got a bad mains tranny? I feel like a chooch saying this, I've been working amps for years, but I've never acctually dealt with a bad mains transformer. Anyone have any thoughts? Any help is a big help. Note: I've been using the schematic found here: http://www.soundcitysite.com/b_150.jpg
macombredesigns
Court Jester
 
Posts: 66
Joined: Mon May 30, 2005 7:01 am
Location: Brighton, MA

Re: Sound City Bass 150

Postby Papa Dog on Sun Aug 24, 2014 12:39 am

1st, check the solder joint where the heater connects to the power tubes. You can get that arc'ing sound there.
I would change the filter caps. They can read good and still be dead short.

There are ways to check the PT for shorts and low resistances...unfortunately I do not have the specs on that transofrmer to tell you what those readings should be.

If the transformer is not getting hot I would doubt that it is bad. BUT, i am NOT a transformer guy...and there are some folks here who know much about them. Maybe someone will chime in with a better answer.

And, welcome to the VAF and to the Sound City site.
There Ain't No Such Thing As A Free Lunch.

"The time has come," the Walrus said,
"To talk of many things:
Of shoes--and ships--and sealing-wax--
Of cabbages--and kings--"
Papa Dog
Knight
 
Posts: 1337
Joined: Mon Mar 15, 2010 6:48 pm
Location: Narly Ampwerks

Re: Sound City Bass 150

Postby macombredesigns on Sun Aug 24, 2014 12:58 am

Thanks, Papa Dog! I've been lurking in the Ampeg section for a while. This is my first foray into the Sound City section. I'll take another look at the heater connection, as one of the leads from the transformer was disconnection when I got the amp. In the mean time, caps are on order!
macombredesigns
Court Jester
 
Posts: 66
Joined: Mon May 30, 2005 7:01 am
Location: Brighton, MA

Re: Sound City Bass 150

Postby macombredesigns on Wed Nov 12, 2014 3:33 pm

UPDATE: New filter caps, and this beasty roars! Now I've just got to track down an original silver topped knob and I'll be in business. Any suggestions on KT88s? Also, anyone have a source on 2BA chassis mounting bolts?
macombredesigns
Court Jester
 
Posts: 66
Joined: Mon May 30, 2005 7:01 am
Location: Brighton, MA

Re: Sound City Bass 150

Postby Papa Dog on Wed Nov 12, 2014 3:52 pm

for 2BA bolts not affiliated or associated with this web site...they just have what ya need.

Dunno what to say about the knobs...I have been trying to source the coloured ones for the Mk4 series...

Oh, yeah...almost forgot...KT88s can be had from several sources.
Last edited by Papa Dog on Wed Nov 12, 2014 5:10 pm, edited 1 time in total.
There Ain't No Such Thing As A Free Lunch.

"The time has come," the Walrus said,
"To talk of many things:
Of shoes--and ships--and sealing-wax--
Of cabbages--and kings--"
Papa Dog
Knight
 
Posts: 1337
Joined: Mon Mar 15, 2010 6:48 pm
Location: Narly Ampwerks

Re: Sound City Bass 150

Postby macombredesigns on Wed Nov 12, 2014 4:13 pm

Awesome! Thanks, bud! You don't happen to know the length of the standard Sound City chassis bolts, do ya?
macombredesigns
Court Jester
 
Posts: 66
Joined: Mon May 30, 2005 7:01 am
Location: Brighton, MA

Re: Sound City Bass 150

Postby Papa Dog on Wed Nov 12, 2014 5:12 pm

the ones I order are 2BAx1-1/4" Hex Screw (2655) they fit the MK4 chassis and I would reckon most other Sound City amps.
There Ain't No Such Thing As A Free Lunch.

"The time has come," the Walrus said,
"To talk of many things:
Of shoes--and ships--and sealing-wax--
Of cabbages--and kings--"
Papa Dog
Knight
 
Posts: 1337
Joined: Mon Mar 15, 2010 6:48 pm
Location: Narly Ampwerks

Re: Sound City Bass 150

Postby macombredesigns on Wed Nov 12, 2014 5:36 pm

Thanks again!
macombredesigns
Court Jester
 
Posts: 66
Joined: Mon May 30, 2005 7:01 am
Location: Brighton, MA

Re: Sound City Bass 150

Postby jaywalker on Sat Nov 15, 2014 3:26 pm

I've been looking off and on for a couple of knobs to replace the two that are missing the silver caps. No luck so far so I'll probably settle for a set of silver cap Marshall set screw type which are tapered instead of straight walled and fluted like the originals. The caps being sold on ebay are for the German type and are not the same as the chamfered B150 caps. If you have an original the mfgr's name is visible from the underside in raised letters. My amp isn't here and the name escapes me at the moment (same as some Marshalls).
jaywalker
Baron
 
Posts: 2373
Joined: Sun Jul 03, 2005 1:11 am
Location: California

Re: Sound City Bass 150

Postby partsstan on Sat Nov 15, 2014 9:54 pm

Hi! I had the same knob problem with my L150 and I took the caps from Marshall knobs and put the line on with a sharpie. looks identical to the originals. :D :D :D
partsstan
Court Jester
 
Posts: 66
Joined: Sun Feb 24, 2008 4:35 pm
Location: RIVERCITY,CA.

Re: Sound City Bass 150

Postby jaywalker on Tue Nov 18, 2014 3:17 pm

partsstan wrote:Hi! I had the same knob problem with my L150 and I took the caps from Marshall knobs and put the line on with a sharpie. looks identical to the originals. :D :D :D

:thumbsup:
jaywalker
Baron
 
Posts: 2373
Joined: Sun Jul 03, 2005 1:11 am
Location: California


Return to Sound City

Who is online

Users browsing this forum: Bing [Bot] and 2 guests