WEM ER40 Fault

Burns, Selmer, WEM, and more

WEM ER40 Fault

Postby jvguy on Fri Dec 04, 2015 2:52 pm

Hi Guys
I have a Watkins solid state ER40 which I bought recently, when I tried it, the amp powered up for a few seconds, worked and died. I then changed all the electrolytic caps and the amp does exactly the same, works for a few seconds and dies. After a leaving the amp off for a while, the amp can be switched on again with the same results. Any ideas would be welcome.
jvguy
Peasant
 
Posts: 12
Joined: Sun Mar 11, 2012 1:46 pm
Location: Argyll and Bute, UK

Re: WEM ER40 Fault

Postby stratele52 on Fri Dec 04, 2015 8:13 pm

Why do you change 'lytics ? Filtering issue ? There is no reason with what you write and what amp does .

I hope it is not because anybody talk about electrolytic or fiters caps for any reason on all amp forum.

Find link for schematic and maybe we can help you .
stratele52
Knight
 
Posts: 1904
Joined: Sat Aug 21, 2010 9:35 am
Location: Québec province, Canada

Re: WEM ER40 Fault

Postby Pitchfork on Mon Dec 07, 2015 11:40 am

Pitchfork
Certified
 
Posts: 152
Joined: Fri Jan 03, 2014 10:39 am
Location: Hampshire U.K.

Re: WEM ER40 Fault

Postby stratele52 on Mon Dec 07, 2015 1:57 pm

Pitchfork wrote:schematics here http://www.schematicsunlimited.com/w/wem/



Thank's , but it is not the schematic , it is link to many Wem schematics . After you have to find wich ones are for ER40 .

More easy link here;

http://el34world.com/charts/Schematics/ ... matics.htm

I wish jvguy , help us to help him with the good schematic .
stratele52
Knight
 
Posts: 1904
Joined: Sat Aug 21, 2010 9:35 am
Location: Québec province, Canada

Re: WEM ER40 Fault

Postby joolzmadcat on Tue Sep 13, 2016 10:24 pm

ER40 PA40 .. same amps.. no difference except the name on the front.. and you can find schematics at the WEM owners club site.. though it's probably a resistor or driver trannsistor.. very simple amps.. usually very reliable.

http://wem-owners.com/schematics/er40-er100-pa40-pa100/
joolzmadcat
Peasant
 
Posts: 20
Joined: Sat Apr 09, 2011 1:09 pm


Return to Miscellaneous British Amplifiers

Who is online

Users browsing this forum: No registered users and 3 guests